Pangolin Wiki

Laser Show Control for Lighting Professionals

User Tools

Site Tools


beyond:fb4_export

FB4 Export

The Pangolin FB4 has an SD card for storing Animation Files. The FB4 hardware can also be used in several scenarios. It can be used by BEYOND and QS software for real time Output. The FB4 can be controlled by ArtNet or DMX. In this case the Animation Files need to be stored on the SD card.

The FB4 uses an SD card with a standard file system. FB4 Animation Files have the extension “FB4Animation”. Each file contains a sequence of Frames. In general, the FB4 can be considered as an audio player. Audio players keep several audio files in the memory, and offer some way to select a file and control the playback of the files. The same story happens with the FB4 hardware. BEYOND and QS prepare files and files can be stored on the FB4 SD card. In the audio world, this process called “mixdown” or “rendering”. Just as there are several tracks for drums in an audio player, there are several tracks for Laser Shows in the form of Frame Files. We may export complex constructions such as Timeline, or Synthesized images, and in either case what we have is an Animation File that is a sequence of Frames.

The analogy of an MP3 or Video player is a good one. Each of the player has settings such as volume, or brightness. It's the same with the FB4 hardware. The FB4 has Playback Settings and has Animation Files on the card. Finally, there are several ways to start and control the playback process.

For making Animation Files, it is recommended that you should use only BEYOND or QuickShow software. The FB4 uses a special file format – the FB4 Animation and it is the only supported file format. The file contains important timing information. The file supports up to 6 colors. Such information cannot be encoded into the older classic formats such as ILDA or Pangolin LD2000 LDS.

Single Cue Export

If you want to Export one single Cue then the simplest solution is the “Cue Export” dialog available in the Grid Mode, Menu File. The Export dialog can export LDS and FB4 Animation files. For detailed information check out the “Cue Export” document. Important detail: Select the corresponding file type in the Save dialog. The default file type is LDS. Several years ago this dialog used to export a Cue to LDS files, and this is source of confusion. You can use this Wizard for export of FBAnimation too.

Once the FB4 Animation File is ready, you can copy it onto the SD card from the software by means of the FB4 Browser window or plug an SD card into the PC by means of a USB card reader and copy the files in Windows Explorer.

You also might want to check the exported file in the FB4 File Viewer and ensure the File Frames Exported as you expected them to.

Variety “FB4 Export”

There are multiple different actions that fit into the description “FB4 export”. First of all – the word ”Export”. It could represent aprocess of Animation File creation, or it might represent a process of Animation File upload, or both. If you need to upload files to the FB4 memory card, then you should use the FB4 Browser window. “FB4 Export” allows the creation of FB4 Animation Files, and initiates the upload process. File uploading is not a required action. You can create files and update them later, or copy them to the SD card right inside PC.

The Export dialog offers several options according to the FB4's Mode:

Test Frame – Standard. BEYOND/QS software has the Standard Test Patterns embedded into the application. This mode should be used for uploading Standard Test Frames into the SD card.

Test Frame – Blank Template. If you prefer to use some other Test Frames then use this option. The wizard will prepare a Blank Template for your Test Frame Files: - you will see it in the next step. It is the only difference between these options. The “Standard” option offers a template with Standard Frames, the “Blank” option offers a clear starting point.

DMX Workspace. Is a great option when “I just want to export a Workspace”. The Software prepares a template with 9 Pages, 48 cues in each, that corresponds to the first 9 Pages of the current BEYOND Workspace.

A few things to keep in mind:

Currently the FB4 has fixed Channel Assignment: - a fixed number of Pages and Animation Files per Page. The Workspace of BEYOND/QS is not supposed to ideally match the dimensions of the FB4 hardware. For the FB3 and LiveQ software it is a different story. LiveQ is built as an editor of the FB3 Memory Card. QS and BEYOND are multi-hardware systems designed to be used for other purposes. Exporting is just one of their functions.

Second. Exporting is not limited to Cues only. You can use external files, as the example shows, eg. LDS and so on.

DMX - Blank Template. Software prepares an empty template with Pages and slots for Cues or Files. It is a good starting point if you do not need a template filled with Workspace Cues.

Auto – Single Files. It is the first of the auto-play modes. The FB4 can play an Animation File when powered up. You can define up to 999 files and select the number of the file you wish to auto-play on startup in the FB4 UI.

Auto – Playlist. By analogy with audio players, the FB4 can operate with a sequence of Animation Files organized in the Play List. In this case the xport wizard creates not only Animation Files, but a Play List File too.

Auto – Daily Schedule. It is the first and simplified version of the Scheduler. Use it if you want to Play Animations at a specified time, every day without any exceptions. The difference between this and a playlist is the concept of time. A Play List is just a sequential list of files. A Daily Schedule is a list of time based instructions – at this time do this, at that time do that.

Auto – Multi-day scheduler. This is the most complex version Scheduler. It introduces the day of week, and date based actions. More details later.

Upload - redirects you to FB4 the browser window.

Open Existing - opens an existing Export Project File. At the end of the process, the Export Wizard offers to save the settings as a file. It allows you to come back and make adjustments, and Export once again. It is important for complex Export Projects such as a Multi-Day Schedule or DMX Exports.

Résumé: The FB4 has several Modes. The Test Mode Wizard offers two options – Standard Frame and Empty Template. The DMX Mode Wizard offers the quick export of the Workspace and a Blank Template where you can place your Files or Cues. For Auto Play Mode, there are 4 options sorted by their level of complexity – single file, list of files, list of files executed by time, and list of files executed by time and date.

Test Frame Export

The Test Frames Projector Mode offers a simpler view with a single list. The FB4 supports up to 999 Test

Frames. To assign the file click on the button. The list has a fixed number of slots/items. You can use drag & drop for reordering, as well as copy / paste. Multi-select is also supported. You can click on Ctrl A to select all the items and click the Delete button. It will delete all the selected items.

Pay attention, in Test Frames Mode the list has a fixed number of items (999). It will not be changed when you delete or add file. The Model is based on other idea. The FB4 has 999 test frames. If you want to use a Test Frame then you select the corresponding place in the list and assign a File or Cue. If you want to assign a Cue from the Current Workspace then use the Menu View > Show Workspace tab.

Multiple operations are available in the Main and Context menus. The Main menu is located at the top side of window. For context menus, use a right click on the list item

Click on the “Export” button to start the Export Settings Wizard.

Summary: The main purpose of this window is to collect several Files or Cues for Export. All that is happening is a list editing process.

DMX Mode

The DMX Export window starts in a dual list view. At the left side is located the Current Workspace. At the right side, there is list of Cues or Files.

The Workspace section looks different, it is not the same as a Grid. It is organized as two lists – a list of Pages and a list of Cues in the Current Page.

There are two similar lists at the right side of the window. A List of Pages and a list of Cues/Files. Each item has its' own number, range of DMX values that will activate this file, original location - File Name or Cue location, and definition – folder and file name on the SD card.

DMX cues on the SD must be saved in the folder: content\dmx\

The file name must follow the Beyond DMX naming standard: character P followed by a 3-digit page number, followed by character C, followed by a 3-digit Cue Number.

Examples:
Example P001C002.FB4Animation - page 1, Cue 3
Example P009C012.FB4Animation - page 9, Cue 12

To add a Cue from the left Workspace List to right Export List list, use a double click. After double clicking, the Cue will be added and the list on the right will jump to the next position. Main idea – use a double click on a Cue in the left side (Workspace List) to transfer it into the right-side (Export List). You can also use drag and drop.

How to Export a page

What do to if I want to Export one or two Workspace Pages? button. Procedure:. Start from a blank template ie. from the Main Beyond Window, File > FB4 Export > DMX Blank Template. Select the Page you want to Export from the FAR left. Select the Page of DMX Values for the FB4 from the NEAR right. Click on the “Assign current button, …” (located at the top of the Far Left (Workspace) Menu).

Hint: The FB4 DMX Page list has a Right Click context menu with a Clear page command.

Cue/File List Context Menu

Assign File – calls an Open File dialog to allow the selection of a file such as a Timeline/Show, Animation, Shape and so on.

Copy – copies the list item into the clipboard. This group of operations is oriented in list items rather than on content.

Paste – paste the list item from the clipboard. Copy/Cut/Paste is oriented at allowing editing operations within the list.

Shift up, Shift Down – shifts all the list items up or down, whilst an adding empty space.

Drag Up, Drag Down – operates like a traditional drag & drop, it simply exchanges the items' position.

Clear – clears the current item

Clear all items – clears all the items from a list

Cue Properties – if the current items in a list include Cues, you might need to check and adjust the Cues' Export Settings. This is important. For example, Abstracts or Shapes don’t have a fixed duration. As a rule, they are endless. But we cannot operate with endless files. it means, we need to the define the duration of the file (start time and duration) before Exporting.

Note: The Export Settings are a property of the Cue. When you change them from the Export dialog, you also modify the Workspace Cue.

Auto Play

Folder structure and general ideas

The Auto play mode operates with Cues and Play Lists. There are two predefined folders:

\content\autoplay\list\###\

And

\content\autoplay\cue\

\content\autoplay\cue\ is used for single files, (mode “Auto – single files”)

\content\autoplay\list\###\ is used for Play Lists. Play Lists can be exported in 3 Export Modes – Play List, Daily Schedule, and Multi-Day Schedule.

### is the list index, a 3-digi number in a range of 001 and 999.

Single File

A Screenshot of Auto Play fora single file is shown above. In this mode the FB4 can display / play one, a single file after power up. The FB4 hardware allows the saving of up to 999 files (subject to SD card space). Operations within the list are the equivalent to the Test and DMX list mode design. The number of items permitted in the list is fixed to 999. You can drag and drop Cues from the Cue List on the left side into the Export List on the right. The Context Menu has a list of operations for opening files, copying, pasting, deleting, clearing, etc.

The files for use in single Cue Mode must be saved into the folder \content\autoplay\cue\

Play List

Auto Play – The list starts with an empty Export List on the right side, and the Workspace View List on the left. You can drag and drop Cues from the left side Workspace List to the right, or use the Context Menu to add files. Operations with the File/Cue list are similar to the DMX or Test mode list design. The difference in this mode is we use the list without fixed number of items. The Export List items here may include one, two or multiple items.

File Names and Structure

BEYOND/QS create several Animation Files and an Index.txt when exporting. Animation Files have name structures such as “file_001.FBAnimation”. “file_” is a standard prefix. 001 and up is the File Index Value which is always between 001 and 999. File naming is not a strict requirement for the Auto Play Mode List, but we use exactly this system during Export.

File Index.txt contains a list of files, and instructions. In fact, the Index File is a sequence of instructions for FB4. Example of Index file for Play list:

LIST
PLAY “file_001.FB4Animation”
PLAY “file_002.FB4Animation”
PLAY “file_003.FB4Animation”
END

LIST is the command for the List Start. END is the command for the :ist Ending. PLAY followed by the File Name is an instruction to Play the File.

Index.txt is the mandatory File Name. All Animation Files must be contained in the same folder.

Hint: It is OK to edit index.txt manually, but find a moment to test it using Play to ensure that you see the expected results. There is a chance of making a mistake when editing manually!

Daily Schedule

Daily Schedule should be used when you want to play files at an exact time, and do the same everyday, without exceptions such as holidays, or weekends. If you have such exceptions – use the Multi-Day Schedule.

The list of cues and files at the right, is empty at the start. You can drag & drop cues from Workspace or use the Context Menu to add files. The Daily Schedule List has no fixed structure, and the number of items is not limited.

Once a File/Cue added to the Daily Schedule, you should notice warning sign. It warns the time has not been assigned yet. Click on the Clock Button () to call up the Settings Dialog. Define the Start Time and define the duration of playback. There are several options:

  1. Until the Next Event – plays the file until the next file is started.
  2. Duration – play the file for X numbers of hours, second, minutes.
  3. Loops – plays the file X times and then stops.
  4. Until Time – plays the file until a specified moment of time is reached. This option might create problems. We would recommend using “Until the Next Event” instead to avoid overlooking Events and ending up with the Time Event and others clashing.

Click OK to close the dialog. You can define multiple Events inside of the Daily Schedule. The application will automatically sort all the created files by time.

Just the same as in the Play list, Daily mode uses the format: index.txt

An example of an index.txt file created in Daily Mode:

DAILY
AT 00:00:00:00 PLAY “file_001.FB4Animation” UNTIL NEXT
AT 01:00:00:00 PLAY “file_002.FB4Animation” UNTIL NEXT
AT 02:00:00:00 PLAY “file_003.FB4Animation” FOR 00:00:10:00
AT 03:00:00:00 PLAY “file_004.FB4Animation” X 5
AT 05:00:00:00 PLAY “file_005.FB4Animation” UNTIL 06:00:00:00

Each list item has a similar syntax. The Instruction AT followed by the time in an HH:MM:SS:MS format. After that the command PLAY with the file name. And finally, the instruction for the duration.

UNTIL NEXT - corresponds to “until next Event”

FOR 00:00:10:00 corresponds to the “Duration” option

X 5 corresponds to “Loops”, where 5 is the number of playback loops.

UNTIL 06:00:00:00 corresponds to “Until time”

Hint: you can adjust the FB4 clock in the “FB4 Settings” window.

Multi-Day Schedule

The concept of the Multi-Day Schedule is based on two factors:

  1. There is a Schedule for every day of the week and the system performs it by default.
  2. There is a “holiday” day – a day where you want to define special schedule, just for this day. This Schedule has a higher priority than a regular Weekly Schedule.

So, when the FB4 starts scheduled playback, it takes the current date and searches for the corresponding Schedule for this exact date. If a Schedule is not found, then the FB4 takes the Current Day of the week, and finds a Schedule for this week day.

There are no other rules or exceptions. Only the two rules represented above.

The Multi-Day Schedule has a modified list of Cue/Files at the right side. There is list of week days. It cannot be removed. To add a Schedule for an exact date use, the Context Menu in the Days List, or the toolbar Schedule Buttons .

A week Day or Date Based Schedule is the equal, and duplicate of a “Daily” Schedule. The list contains a variable number of Cues or Files, and each item has a Start Time and Duration Setting. Please check the previous section for Daily Schedule.

Example of the file format for the “index.txt” in Daily Mode:

MULTI
ON SUNDAY AT 01:00:00:00 PLAY “file_SUN_001.FB4Animation” UNTIL NEXT
ON SUNDAY AT 02:00:00:00 PLAY “file_SUN_002.FB4Animation” UNTIL NEXT
ON SUNDAY AT 03:00:00:00 PLAY “file_SUN_003.FB4Animation” UNTIL NEXT
ON 2017-09-15 AT 05:00:00:00 PLAY “file_2017-09-15_001.FB4Animation” UNTIL NEXT
ON 2017-09-15 AT 06:00:00:00 PLAY “file_2017-09-15_002.FB4Animation” UNTIL NEXT

The initial command for a MultiDay Schedule is MULTI. After the initial command follows the instructions for each file. The definition of the file fits into a single line. Each line starts from the command ON. After that follows the day of the week – SUNDAY, MONDAY… SATURDAY, or the date in a YYYY-MM-DD format. After that follows the command AT with the start time in an HH:MM:SS:MS format. This section has the same structure as the Daily Schedule. Please check the Chapter about the Daily Schedule for details.

Summary: The Play List and Schedule Modes operate with an “index.txt” file that contains a list of FB4 Animation Files. An Animation File, as opposed to files used in DMX or Test Modes, may have a flexible file name. There is no need to keep it as 001, 002 or so. The Index File and the Animation Files are located in the same folder. We recommend you follow this recommendation. It allows the renaming of a folder within the Playlist/Schedule whilst ensuring it will not break the inks. The “Index.txt” file can be modified manually, but it takes practice before doing this. Keep in mind, the FB4 clock may be set up inside the FB4 Settings window.

Saving the Project File and some Basic Hints.

Creating a project file might be a time consuming process for DMX or Schedule Exports. Before starting file creation, BEYOND/QS will offer the option to save the profile as a template file. When it is done, you can open it later, as the initial window offers it as the first option.

When you save a project, please make a folder and give it a name you can remember. Do not make a folder containing tons of Exports Projects. It might be good idea to select this project folder as the location for saving the FB4Animation files.

The Export process has two logically separated steps.

Step 1 – to create Animation Files.

Step 2 – to upload Animation Files to the SD card. The software can create the Animation Files much faster than the files can be uploaded. A 100mbit network is not really fast for large file sizes, and so the upload process might take some time. Sometimes saving a copy direct to the SD card in a USB Reader on the PC might be faster. In fact, it should be faster. Consider it as a hint for a backup plan. Plus, for these reasons, do not leave the file upload process to the last minute before a show.

Keeping the Exported Files in same folder as the Project File is a good idea. There is no requirement to do this, but it is good to have a system when it comes to filing.

If the upload stops for any reason, you can upload files later by means of the FB4 Browser window.

Uploading to the SD card and streaming from BEYOND/QS should not happen at the same time. There is a d small chance of an overlap, but this then creates a problem for streaming, as well as a major decrease in the upload speed. Most possibly it will be blocked in upcoming versions.

Export Wizard

page 1

We've tried several versions of uploading windows. BEYOND and QuickShow have different versions and both caused some questions from Users. Version 4.0 offers a new version of the Exports Settings Panel, implemented as a Wizard.

Here we will explain each option, and how it influences an Animation File.

page 2

The only question at this step is whether to apply Geometric Correction and Color Mixing or not. If you select “No correction” then the software Exports the frames in full size and RGB colors, without any correction, or modification. The Color Settings may change frame a lot… really. You may export with Single Color Settings, or 6 Colors, or some other setting. In practice, it means – there is no original RGB color. It's a similar story with co-ordinates: The Geometric Correction, Master Settings and BAM will modify Frames, and once modified, the Frames cannot be returned back to their original settings. OK, it is a consequence, but this is not a bad consequence.

If you want to create files “same as it projects from BEYOND” then you should select the option “Apply Color and Geometric Correction”. BEYOND/QS uses a code for output processing as in the case of real time streaming to FB4 Hardware.

One more detail to keep in mind. A File without correction can be used in multiple projectors. It is kind of a universal File. The Master Size can be changed in the FB4 Setting, and as well as some basic Color Correction. Of course, the FB4 Settings will be applied to any file, but a double correction might be confusing.

Summary: At this page, you define and apply Geometric and Color Correction if required. If no correction is required, then the file will be created with full size XY and RGB color.

page 3

Incorrect selection here may lead to problems. A typical symptom of making the wrong choice is a black Frame File.

The best example is the Multi-Projector Timeline. This Timeline has several Tracks that produce the Output for the corresponding Projectors. If we ignore the fact there is a relationship between the Projectors and the Frames, then we will have them “all together”. Of course, we want to make sure the Timeline runs correctly and takes into account the destination settings, and sends the track Output to the correct assigned Projectors. If in such case, the file ignores the Routing settings, it will lead to problems.

Let’s consider another simple but opposing scenario. We have a “stock” Workspace where all the Graphics content is sent (by default) to the “Main Graphics” Zone. This Projection Zone can be assigned to one Projector. Now, imagine we want to Export these graphics Cues into several different Projectors, but the Cues are all assigned to Main Graphics. What we should do? First way – change the Cue Settings. Second way – introduce a special option that allows the FB4 to ignore the Cue assignment contained in the Cue Settings for the Projection Zones, and instead produce equal files for all Projectors. If we will not do this, then only the Projector assigned to Main Graphics will have some Output. All other Projectors will just have black Frames.

In general, it is not too complex, but might be confusing or unexpected when first learning. Keep in kind mind the example of a Multi-Projector Show and a Simple Frame, and it should help to memorize the difference.

Page 4

At this step, you should define the Projectors to be assigned for File Calculation and upload.

page 5

The only difference between these options is to start the upload to connected a FB4 or not. The Export process has two steps anyway. Firstly, the software creates Files, and secondly, the software starts the file upload. The second step is optional. If you need only the Files then use the first option. If you want to upload files right now, then choose the second option.

page 6

Select a folder for the FB4 Animation Files.

Strong recommendation – use a local hard disk. Do not export onto slow media such as an SD card, or USB flash drives. Use a local HDD or SSD.

Main requirements – select a folder where the software will be able to create the Files and ensure the disk has enough available space.

Give the folder a memorable name or use the same folder where you saved the Project File. There are no strict rules for folder location or naming, but reasonable names are recommended.

Immediately after completion of the naming stage, this page will appear and start the Frame Calculation process:

Export Progress and Final Page

BEYOND/QS software uses several CPU threads for File Calculation. This ensures the Export process should as fast as possible, although it all depends on the contents' complexity and CPU speed. As soon as the File is ready for upload, the DFile will be redirected to the uploader module of the software. Upload is a background process and can work at same time as calculation. You may check the upload progress and the result in the FB4 Browser Window. The upload status is also displayed in the Status Bar of BEYOND/QS.

As soon as you see the “Export complete” page, you can close the Export Wizard. By now, all Files are created and the File preparation process is complete. You may also close the Main Export Window (it will show up after closing the Export Wizard).

Monitoring of the Upload Process using the FB4 Browser Window.

Click on the Status Button to see a list of completed and upload pending Files.

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
beyond/fb4_export.txt · Last modified: 2019/09/07 11:24 by Bob Varkevisser