Pangolin Wiki

Laser Show Control for Lighting Professionals

User Tools

Site Tools


beyond:projection_zones-new

Projection Zones in BEYOND

Introduction

BEYOND includes Pangolin's exclusive ILDA-Award-winning Projection Zones technology, that allows BEYOND (running on a single computer) to access a virtually unlimited number of projection areas (zones), either from a single laser projector, or from up to 24 laser projectors.

As BEYOND can control a virtually unlimited number of laser projectors, if you need to control more than 24 laser projectors at a single event, you can use multiple computers, and network those together within the BEYOND software.

Projection Zones in BEYOND

BEYOND software has a few improvements in the Projection zone system. First, BEYOND uses a zone’s name as a method of zone identification. LD2000 and QS use the number of a zone in the list (index of zone). Using the name as an identification tool allows you to easily move zones up and down in the list, unite zones and most importantly – The name of a zone can provide an indication as to what the zone is. For example, one BEYOND client can place a zone (i.e. hot beams) in position number 10, while a different client places it in position 20. Using this new identification tool, clients can easily exchange the data (frames, shows, etc.) and the frames will go to the right destination.

Projection Zones combine the projector selection guide along with a variety of other tools to help you control your zones.

These include:

  • Geometric Correction - Which allows you to control a zone’s size, shape, position, rotation, etc..
  • Preview Window Appearance - Allows you to preview the appearance of a zone.
  • Beam Attenuation Map - This is a safety tool that allows you to control the brightness of a zone.
  • Also To - A tool providing options for routing output from the specific zone you are setting up to additional zones (similar to using a hardware splitter between zones).
  • Effect Tab - Where you can set an effect that can always be applied to the zone and work as a filter.
  • Advanced Tab - Where you can prevent other settings from impacting a zone along with an External Visualization fixture number setting, for use with an external visualization applications (like Capture Polar, Realizzer or Light Converse).

The list of projection zones can be seen and selected on the left side of the window. When you click on a zone on the left side, the tabs on the right allow you to view and adjust the parameters for each projection zone. To view and adjust the parameters, click on the Geometric Correction, Preview Window Appearance, Beam Attenuation Map, Also to, Effect, or Advanced tab.

Hint: In recent versions of BEYOND, it is possible select more than one projection zone in the list and adjust them simultaneously. Multi-Zone editing can be used for Geometric correction, BAM and Preview Settings tabs.

NOTE: When a listing is red, it is because there is no laser controller that is able to output to that projector (scanner).

At the top of the Projection Zone settings menu there are 4 typical menu options - File, Edit, Output, and Zones. These are discussed in the next section

File, Edit, Output, and Zones

In the File menu dialog, you can select “New”, to clear out all custom Projection Zone settings and restore them all to their default settings, “Open”, to open a saved Projection Zone settings file, “Save”, to save out a Zones file with custom Projection Zone settings made, and “Exit” to exit the Projection Zone settings dialog.

In the Edit Menu dialog, you can select a Zone and choose “Copy”, to copy all the selected Zone’s settings into Clipboard, “Paste”, to replace all of a Zone’s settings, with settings from a Zone that you have copied, “Reset” to reset the Zone settings to default for a Zone you have highlighted, or “Reset All” to reset all of the zones listed, to their default settings.

In the Output menu you can choose your method of displaying Projection Zone test patterns. You can choose to do this automatically when the Zone settings are opened, or to have no test patterns displayed so that you manually have to do it (this is the default setting, for safety reasons). You can also choose to disable all test patterns.

In the Zones menu you can add or delete Projection Zones.

Most of these tools are also located on the Projection Zone settings’ tool bar, with the addition of an “About” Projection Zones button and a Master Brightness slider.

Projector (i.e. Scanner) Output

The area toward the top of the General tab, labeled “Output this zone to” allows you to indicate the projector (Laser Controller Serial number) that will be used for that zone, and also to adjust the parameters for that projector. This is how you indicate which projector will be used for each zone. Pressing the “Settings…” button will display the Projector Settings window.

Our recommended order of settings is as follows:


  1. Set the order of controllers in the Laser and EmuLaser hardware dialog

  2. Adjust the Projector Settings
  3. Adjust the Projection Zones

Controllers and Projectors are sort of “low-level layer” that reflect a real hardware setup. Projection Zones use a higher level setup.

Projector Zone Names (Identifiers)

Projection Zone Names allows you to specify one or more Projection Zone Names. Since there are many zones, you should give a descriptive name to each zone for identification, such as “Main Graphics” or “Scanner 2 Beam zone”.

The Zone Name is very important because it is used for content (shows, frames) and that content will memorize this name. If the content uses a zone’s name that does not exist, then output for this content will be blocked. This is done for safety reasons.

Zone Names are also used as identifiers of Zones within PangoScript. The identifiers have rules. The identifier must start from with a character (A..Z), and contain both characters and numbers. Spaces, delimiters and other characters are not allowed. The name cannot start with a number either.

While this may seem restrictive, it is actually a standard rule for various programming languages. NOTE: You only need to remember these rules, if you will use PangoScript.

BEYOND automatically creates a zone identifier from a zone’s name – BEYOND removes the spaces automatically in this regard. For example, “Main Graphics” will be transformed to “MainGraphics”.

Additional Zone Names

Zones may also have more than one name. All additional names work in the same fashion as the main name does. The secondary (additional) name can be helpful if you take content from another system that uses other zone names, and you are not able (for various reasons) to modify that zone’s content settings (for example if you were programming a show, for another company). In such cases, you can assign additional names to some of your zones, and work with the Content in this way.

Mute Zones

This allows you to temporarily block output from a zone.

Test Pattern Control

Two boxes next to the Zone Name allow you to display a test pattern if desired, and it is possible to project a test pattern on multiple zones simultaneously in this mode. This allows you to adjust geometric correction settings on overlapping projectors.

There are two different test patterns available for selection: a Simple test pattern and a Grid test pattern. The simple test pattern has roughly 500 points, and the grid test pattern has roughly 1000 points. Using the simple test pattern (when you are projecting multiple test patterns from the same set of scanners) will help to reduce flicker.

In addition to the lines that make up the actual test pattern, each test pattern also has an identifying number to help distinguish which test pattern is being projected from which zone.

Geometric Correction

The Geometric Correction settings allow you to adjust the geometric correction for each projector. In addition, each projector can actually have multiple geometric correction settings (if desired) simply by directing more than one zone to the same projector.

To adjust the geometric correction in BEYOND, you have two options. First, you can use the Universal Geometric correction tools (similar to QuickShow and LD2000) or you can use the Free-form Mesh tool.

To use the Universal Geometric correction tools allow you to click on one of the different Correction Types and then move the sliders that appear on the sides and top of the window, or you can click and drag the mouse in the window area. Each correction type has a reset button and there is also a reset all button to reset all the correction types.

To use the Free-form Mesh tool, click on the Free-form Mesh tab and click and drag one of the “dots” to change the geometry of the mesh. You have 4 options for the level of control you want in adjusting the mesh’s geometry. Each option will give you more or less “dots” (i.e. change points) on the grid. The more “dots”, the more detailed changes you can make to the mesh grid. There is a Reset button available if needed. The Mesh mode is very helpful if you need to overlay output from one projection zone on top of another. It also helpful if you need to connect zones side by side using the “Also To” function.

Hint: We recommend to start with the most simple mesh mode (1×1) and setup the corners. After that go to 3×3 and adjust center and linearity of the boundary lines. If this is not enough, go to 5×5 and adjust further. We do not recommend starting from the 5×5 or 9×9 modes.

NOTE: During development, we tested what would happen if we were to use the Universal Geometric Correction Settings together with the Mesh. Our conclusion is that these do not work well together, and can lead to confusion. The main advantage of the Mesh, is that you control the points directly, without the need for additional corrections.

Preview Window Appearance

The Preview Window Appearance tool allows you to adjust the appearance of a zone in your preview window. NOTE: It is possible to specify a Preview Window Appearance for each projection zone, and this preview window’s appearance is independent of the laser output - So master size, position and geometric correction do not affect the preview window.

For each zone, the Preview image’s size and position can be adjusted. You can also specify whether the preview for that zone should be normal laser graphics, or audience scanning beam effects.

If you specify that the preview should be Audience Scanning Beams, you will see a few more options. You can control the vanishing point created by the actual projector position (Position X, Position Y sliders). You can also choose whether or not to mirror the output and the position in the preview window.

You would mirror the output and position when you are sending the output of a single FB3 to multiple projectors at either side of a stage. When this is selected, the preview window automatically duplicates and mirrors the output even though there is only one signal source for both projectors.

There are also settings for Enhanced Reality preview that adjust virtual fog levels and distance for a simulated scrim or gauze screen.

NOTE: With all of this flexibility, you can adjust the preview window for each zone to truly simulate what the show will look like in the final venue.

The Beam Attenuation Map (BAM for short)

The Beam Attenuation Map allows you to control the brightness of a laser projector over the entire projection zone that it will correspond to, and it also allows non-uniform brightness maps. You can see a quick tutorial video about the BAM here: https://www.youtube.com/watch?v=89xLGkicUjI

The Beam Attenuation Map is a 64 by 64 “pixel” brightness control map. Each pixel can be set to any brightness level from 0 to 100%. Rudimentary tools are provided to sample a brightness level in the map, fill the entire map with the selected brightness level, fill a rectangular area with the selected brightness level and freehand-draw brightness levels into the map. Additional tools allow you to draw a gradient level of attenuation so the brightness of the BAM varies between two different attenuation levels.

Once you set a BAM for one zone you can copy these BAM settings to be applied to multiple other zones and have a bitmap screen shot of your drawn BAM copied to the clipboard, to be pasted into a document for possible use in a Laser Projector Product Report.

The Beam Attenuation Map can be used for graphics, atmospheric and beam effects.

Below is an example of a Beam Attenuation Map used for laser graphics.

One common use for the BAM, as it related to graphics, would be to prevent scanning above or below a certain point. For example, lets say that you were projecting laser graphics over a standard television screen with a 4:3 aspect ratio. Since the laser typically has a 1:1 aspect ratio, this would mean that the graphics could possibly scan above the top or below the bottom of the screen. You can use the Beam Attenuation Map to make sure that the brightness at the top and bottom of the screen are zero. Similarly, the window-clipping action can be done by means of the Effect tab.

Example Beam Attenuation Map used for audience scanning

Another common use would be to reduce the brightness below the horizon to a level that would be more pleasing for people in an audience scanning area. This can easily be done by selecting a reduced brightness level, and filling the rectangular area below the horizon.

Example Beam Attenuation Map use with targeted beam effects

Another common use would be to protect certain areas from hazardous laser exposure or to reduce the brightness in certain areas. When doing beam shows outdoors, it is often necessary to ensure certain areas (such as the windows in certain buildings) won’t be exposed. Using the rudimentary drawing tools, it is possible to “carve out” areas from the projected area.

The Advanced Tab

his section shows the Advanced Tab Parameters for a selected zone, and allows you to adjust them. These are advanced scanning parameters that are particularly well suited for zones used with targeted beam effects.

When the Prevent master size and master position check box is checked, it will make it so that the Master Size and Master Position controls in the Projector Settings window do not affect the output of this zone.

When the Prevent 3D settings and Showtime effects check box is checked, it will make it so that the output of this zone is not affected at all by any effect that would cause beam frames to no longer hit their intended targets. For example, if you painstakingly adjusted the position of a beam to precisely hit a mirror, you would not want the position of this beam to be affected in any way. The two options above ensure that even if you mistakenly use effects that would change the position, or accidentally change the Master Size settings, these beams will continue to hit their intended targets.

NOTE: Zones with this option can sometimes cause confusion, because they disable some Live Control functionality of effects on the Timeline.

The Minimum number of points setting in the Projector Settings window can be adjusted to relieve the scanners from trying to scan high duty-cycle which may cause power limiting. Setting the Minimum number of points to 200 or higher can actually increase the life of your scanners. However, doing so will mean that if you project less than 200 points, the additional points will be blanked. For beam frames, it is often undesirable to have any unintended blanking at all because such blanking would tend to reduce the power of the display. When the Prevent minimum number of points check box is checked, all scanner output will be dedicated strictly to producing laser output and the Minimum number of points setting is ignored.

External Visualization

Here you can assign a fixture number to the selected Projection Zone for use with an external visualization application such as Realizzer, Capture Polar or Light Converse. The fixture number set here will route laser information to a corresponding fixture number within the external visualization application.

How to Handle Unresolved Zone Names

This is where you can see how many cues or content within your Workspace are being routed to Projection Zones that do not exist.

Effect

Here you can apply an effect to the selected zone so any content played on that zone automatically has that effect applied to it.

This is not a “live control”. This is not a dynamic setting. This is not an Effect in the classic understanding of BEYOND. So, what does the Effect do? … It transforms the frames that are projected to this zone and applies an effect to them.

In some cases, you may want add an effect that will modify all frames that go to a certain zone. BEYOND has nice RC key effects, that can work as “smooth” filtesr.

One more reason for this tool, is for external DMX control of BEYOND. Effect allows you to easily organize external control of Zones via DMX, including User, Oscillating and Key Effects. Each Effect item can be linked to DMX IN by means of the Input option.

The “Also To” Feature

“Also To” was designed for two primary purposes

  1. Copy the output of a zone to another zone(s). It helps if you need to add projectors to BEYOND that will duplicate some of the previously existing projectors.
  2. Create a Zone, that consists of two or more zones. For example, you can create a zone that will use two projectors to display content. You can Enable Window and Resize processing so that only certain areas of the selected zone’s output are displayed in the Also to routed zone.

BEYOND calculates the output for each projector independently. This means that each projector has its own time, and the core calculates the frames of time for each projector. This time difference is not visible on a short frame, but it becomes very noticeable on long frames. Window clipping is not a solution for the display of really complex graphics. Results depends on the content.

Sending Cues to a Specific Projection Zone

Projection Zones can be specified within BEYOND cues, so that when you trigger a cue, it will automatically be sent to one or more specific zones. This is the simplest scenario and we recommend to start from it. See the help topic about Cue Properties for more information.

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
beyond/projection_zones-new.txt · Last modified: 2019/08/02 13:32 by Bob Varkevisser