Complete Help Docs

Laser Show Technology for Lighting Professionals

User Tools

Site Tools


pangolin_media_tracer

Pangolin Media Tracer

Manual for the Pangolin Media Tracer, a Companion app for our BEYOND software, first available during the BEYOND 5.8 release.

What is the Pangolin Media Tracer?

The Pangolin Media Tracer (or PMT) allows users to take in graphical media and convert it to laser graphic content. This tool was designed to be creative tool agnostic, which means it doesn’t matter what tool or source you use to create the original media, the media tracer can take it in and create clean and efficient laser lines quickly and efficiently. This should enable the tool to be usable by more artists with different methodologies and creative processes. Without focusing on a single tool that is popular today and making it useful for years to come.

Load in All types of picture files (PNG, JPEG, GIF and more) Vector Files (SVG and AI) Video Files (MOV, MP4, and more) and live inputs (Webcams, NDI) and convert it live or use it to optimize your frames for a perfect conversion.

The Pangolin Media Tracer Is comprised of 3 main parts. The detection choices, Playback area, and optimization settings. The PMT can be used extremely quickly by just loading media and exporting to BEYOND, or used very in depth with different trace layers, masks, video splits, and the full point optimization settings based off the Laser Show Converter MAX render.

And with the bells and whistles needed to do things like quick video tracing with detachable video, Live input options, layering, masking, and splitting of videos into segments. The PMT has every tool a designer may need to create laser content from external media sources.

Getting Started

The Pangolin Media Tracer is part of the BEYOND install starting in the 5.8 Release. To launch the PMT, right click on any empty cell in your workspace, highlight create, and select the “Pangolin Media Tracer”. This will launch the app directly from the installed folder.

(Insert Integration Picture)

NOTE: For the PMT to work, you must download a fresh installer for at least the 5.8 release so that it can be properly installed within the BEYOND Folder. If you upgrade from the “In App” updater, the PMT is not included and cannot be updated. All PMT updates will be provided through full installer releases, as it is a companion app to BEYOND and not directly inside the BEYOND application.

As BEYOND is already running, the PMT app will automatically connect to your active BEYOND software. If the zone selection dropdown says, “Waiting for BEYOND” It is not connected, if it is connected you will see available zones in your BEYOND install.

To load your media, click on the open button on the main toolbar. This will then ask what kind of media you would like to open. From there you can open any and all types of media.

Once the media is loaded, it will begin to be traced by the PMT utilizing the default settings. And you can see the trace. We recommend adjusting the opacity of the background image to your liking, and enabling points to see how the tracer is placing points.

Because media comes in all shapes and sizes, it’s recommended to try a few of the presets on the detection panel to see which might work best for this specific media you are trying to trace.

List types and give descriptions

Once you are happy with your detection, you can then move onto point optimization. Similarly for detection, we have provided some presets that you should try and check the total point count to find the right value for your needs.

List types and describe when to use them

You can select a zone from the dropdown and enable laser output to preview your traced media.

Once you are happy, ensure the cue you want to export your trace to is selected in BEYOND. This is where the PMT will send the animation to. Then in the PMT, click export and choose what you would like to export, this changes based on the kind of media you have loaded and other settings you may be using. But For pictures, export trace and for videos export animation are your most likely choices.

The PMT will then render the full animation or single frame and place them in the empty cell you started on in BEYOND. You may then close the PMT, or just select another empty cue, and load different media in the already loaded PMT window, and follow the same process.

App Sections

Each section of the PMT app serves different purposes and is organized by what the task at hand is. Below we cover each section in detail and describe how to use them.

File Menu

The File Menu is where you will find all of your main control functions that also buttons around the application. The only function here that is not available somewhere else, is the separate preset options as well as the settings menu.

Settings Menu

Most things in the PMT are rather simple, but one function that is less obvious is the OSC communication, allowing remote selection of presets. Good for live input from external media sources, you can bulk select media triggers and live control the selected preset for best live tracing results.

View

The view menu has the view options of showing points and blanking path, which can also be found in the main menu buttons.

Render

The Render menu has all render options, these options can also be found in the main button area. All exports go to the currently selected cue in BEYOND, if content exists in that cue, it will be written over by the export.

  • Export Frame: Exports currently selected frame in the PMT completely.
  • Export Trace: Exports the currently selected trace layer in its entirety.
  • Export Split: Exports all layers but only for the currently selected video split.
  • Export Animation: Exports Everything, all layers, and all splits.

Help

Tells you the current build of the PMT and takes you to this page.

Main Button Menu

Master Buttons

The main button menu is the buttons available to you along the center player pane. This includes Most of the buttons available to you in the main menu, but as hard buttons.

Open is for opening the source material, you will have the options for files, or live inputs. The File types available are defined in the windows Context menu, and in the getting started section of this document.

The zone selector dropdown is where you can see the current zones available to the PMT through the active BEYOND Session. This is updated frequently, but not immediately on change in your BEYOND Session. If the zones haven't updated, enable and then disable laser output from the PMT, or just relaunch the PMT from BEYOND.

The enable/ Disable button works just like BEYOND where it will “show it now” on the selected zone. This is constantly tied to the esc button like in BEYOND so if you quickly need to disable output while in the PMT press ESC on your keyboard.

The Export button allows you to choose which export you would like to do, each described below:

  • Export Frame: Exports currently selected frame in the PMT completely.
  • Export Trace: Exports the currently selected trace layer in its entirety.
  • Export Split: Exports all layers but only for the currently selected video split.
  • Export Animation: Exports Everything, all layers, and all splits.

Media Options

The media options are related to what kind of media you are using, single frame picture media will have less options and live inputs wont have a timeline, but loading video media will show it all and we will use that to describe these options.

Merge Previews allows you to see the traced image on top of the media, when unchecked you get two separate windows of the media, and rendered content separately.

Show Points, and Blanking turns on and off visibility of the points and blanking of the laser frame in the preview area.

Detach video will separate out the background media onto a separate window so you can use the PMT as a single media playing and tracing tool for live video tracing.

Opacity will change the brightness of the source media under the laser traced lines in the merged previews mode.

The timeline is where you can see at what point in the loaded media you currently are, you can use the play and pause button to start and stop or use the space bar. You can also use the split button to separate the media into different sections if you need different trace layers or optimization settings for each section, or to just cut out unneeded sections of media. And finally, you can use the arrow keys in the bottom right of this panel to go frame by frame, or use the arrow keys on your keyboard to navigate back and forth.

Bottom Frame Data

On the very bottom of the main preview panel is statuses of the media and overall trace.

  • Input FPS is the source materials framerate
  • Output FPS is the current render speed of the tracer (While live, renders will always be at source FPS)
  • Source lines is the number of detected segments by the current detection settings.
  • Points is the total number of hardware points the current frame is, and is outputting to laser including all visible and blanked points and lines.

Detection Panel

The Detection Panel is the area that we use to determine how the original media will be traced. This section is broken down into a few main sections.

  • Trace Layers
  • Tracer Presets
  • Trace Mode
  • Affected Area
  • And configuring settings

These are “order based” and cascade from the setting above.

Trace Layers

Trace layers are how you can create separate detection settings to compose a complete image. This can be useful if you are trying to use the PMT to accurately trace a corporate logo, or create different types of trace types all within a single render.

Each trace layer has unique detection settings, as well as optimization settings. So be mindful that your point settings options are different on each layer. As well as any detection options you select below.

Once you have multiple trace layers, you can turn a view on and off to hide layers, as well as delete them with the trash can icon.

You can rename layers by right clicking and renaming. As well as copy and paste all cascading settings between trace layers.

Tracer Presets

Trace Presets are preset detection settings you can try for your media. They are provided as a convenance to users and hopefully give quick settings for most media content loaded into the PMT.

You can also store your own presets by clicking the add button, which will take all the settings below (active on the currently selected trace layer) and store them. You can right click a preset to rename it. These presets are stored in your active BEYOND folder. And can also be saved under the file menu if you would like to move user presets from PC to PC or BEYOND install to BEYOND Install manually.

Under the “Properties” option when you right click, you can find the OSC Address for this preset.

Provided Presets are the following with their descriptions.

  • Media Silhouette: Content is a rendered piece of content like VJ media, where a silhouette look is desired. Use when there is clean lines and defined colors to a background.
  • Media Centerline: Content is a rendered piece of content like VJ media, where a centerline look is desired. Use when there is lots of thin lines in the content with defined background.
  • Gradients: Content is a rendered piece of content like VJ media, where there is a lot of faded edges and gradient colors. This filters the noise and finds a central line over a gradient to place lines. Undefined background.
  • Noisy Media: Content is very busy, lots of noise and colors, badly defined background. Tracer will find the most important pieces and filter the rest.
  • Logos: Content is a non-vector logo file. Logos have clean defined backgrounds and high resolution. Tracer has low filtering and high focus on line accuracy with little simplifying. Noise likely if content is not clean.
  • Hot Points: Content is to be rendered as hot points. Filters out all color and splotches, instead focuses on circles and blobs to turn into centered hot points. No lines will be produced.

Trace Mode

The Trace mode is the type of line detection that will be used for the selected trace layer. At release, there are 4 main detection modes.

  • Silhouette: This will search for edges in the loaded media based mainly on contrast. Then color those lines based on the brighter and closer color to the detected line. This works well for complex multicolored media and clean lines. And generally creates a “outline” of what you are tracing.
  • Centerline: This mode detects an object, and finds the center of that object to place a singular line onto. This is great for line drawings, or extremely complex content, when detail would overload the number of points in a frame.
  • Color: This mode allows you to select a particular color from the media for the tracer to search for. Isolating that color from everything else and allowing you to trace a single part of a much more complex image. This works very well for colorful images where only one part really matters.
  • Hot Point Center: This detects Circles and blobs of individual colors and then centers a hot point there. Hot point density and brightness depends on the largest detected circle/ blob and the smallest detected circle/ blob. This can work extremely well for detecting a single hot point you want to use as a “laser beam cutting into video wall animation” type looks.

These trace modes serve different purposes and are better for different content, so we suggest trying them all while learning the tool Different presets will utilize these different trace modes.

Affected Area

The affected area allows you to determine where in the media you want to focus your traces, basically acting as a mask. You have three main choices:

  • Global: Trace detection looks over the entire media source with no exclusion.
  • Local: This tries to detect the selected object. Tries to connect that object into a closed object, and can grow and shrink based on how it detects that object. It uses a number of factors to determine what an “object” is, but you just select that object in the play area to detect it.
  • Mask: Masks allow you to draw an area over the preview area to either select in, or exclude. You can draw a square or circle, and flip the mask to include or exclude that area. Masks have handles and can be adjusted when made visible.

Configurable Settings

Each Detection type has slightly different options, but general slider choices and what they do are described below:

  • Auto Threshold: Auto Threshold will automatically detect the overall brightness of the scene and determine the correct place to put the trace.
  • Threshold: Manually set at what average brightness the trace should Detect.
  • Blur: Blur will soften the source content to remove noise for detection.
  • Close Gaps: Close gaps determines how much spacing between closed shapes are allowed in the trace, increasing this number will spread out your lines and reduce some noise and create more consistently sized closed shapes.
  • Dilate: Dilate allows you to make the detected lines farther away from the source. This can help circles look better on laser output by spreading the points away from where the scanner will need to actully be while scanning.
  • Edge Trim: Edge trim will cut all lines that connect to the edge of the frame, on by default to save poitns in your final image. Disable to get closed shapes along objects cutting on the edge of the frame.
  • Min Length: Minimum length is the shortest length of object to be detected. If you have many small shapes that are not needed, increase this number to filter them out.
  • Max Contours: Max contours is the number of verticies on a detected object allowed. This acts as a filter for unnecessarily large objects and can filter detection of extra noisy objects.
  • Simplify Mode: Simplify mode is the method of simplifying the output frame from the source material. This can be useful for reducing noise or removing detail to reduce points.
  • Tolerance: The tolerance is the multiplier on the simplify mode, increase this value to simplify the laser frame from the source material more.
  • Enable Smoothing: Chaikin Smoothing is an algorithm to smooth out the input data to create a softer render off of a harder traced image.
  • Max Source Lines:Max Source Lines is the number of verticies detected in a frame. Reduce this value to create a limit to the amount of detail traced.

Optimization Panel

The optimization panel is the actual renderer system from where we take the detected lines, segments, corners and more from the detection panel, and convert them into actual laser points.

This renderer is closely related to the LC MAX render used in the 3DS Max laser plugin, and then iterated on for the Cinema 4D plugin, and Blender Plugin. This system allows users to fully optimize their render based on point count needs and separates the PMT from other tracing systems.

The default settings are a great place to start, and most users should get good clean lines out of the PMT with them. However, if you are looking to sharpen corners, reduce points on straight lines and control anchors this is where you want to go.

Point Spacing Presets

These presets work just like our trace presets, where you can select them for the actively selected trace layer or video split. and are provided as a convenient way to try different settings to find the best option for your source media.

You can create your own presets, rename them, and also access them over OSC the same way as tracer presets.

Provided are the following Presets and their descriptions.

  • Straight Lines (Dense): Lines are mostly straight, corners are closed, very accurate representation of image, might be point heavy.
  • Straight Lines (Sparse): Lines are mostly straight, corners are closed, less accurate representation of image, trying to be low point count.
  • Curves (Dense): Lines are mostly curved, hard edges won't have hard corners, but curves are accurately represented, may be point heavy.
  • Curves (Sparse): Lines are mostly curved, all edges rounded, low point count, but may result in “mushy” lines.
  • Balanced (Dense): Image with Lines corners and curves, Point Heavy but Accurate.
  • Balanced (Medium): Image with lines, corners and curves, Balanced points to image accuracy.
  • Balanced (Sparse): Image with lines, corners and curves, Prioritize low point count, can be mushy or inaccurate.
  • Sharp & Pointy: Image is mostly points, or want corners to be sharp, minimizing all other line types.

Laser Output Render Size

The Laser Output render options dictate two main things, the resolution the points will be rendered at within the frame, and then minimum and maximum limits.

For the render width and height. It will normally load content at its source resolution to start. Live inputs will be loaded at lower resolutions for performance. If you have excessive noise, or reduced performance this can be adjusted.

Adjusting the render width will automatically adjust the height to the original media aspect ratio. Adjusting the render height will detach the render from the original aspect ratio.

NOTE: This resolution and aspect ratio will be put into a 1:1 aspect ratio laser frame. Actual render resolution is relatively meaningless once laser frames are created, and most don't need to go above 320×320, however for some things like logos, more resolution will give a more accurate trace. Its also important to note, If you render media not at a 1:1 aspect ratio, it will not fill an entire laser frame. and instead place that aspect ratio within the full 1:1 laser frame. Set the resolution to a 1:1 aspect ratio to fill a laser frame.

Minimum points is the minimum number of points that will ever get placed in a frame, blanked points will be created if the source visible points go below 200. Maximum points is a hard cut for the renderer. If you want to just forbid the render from ever making more points then a set number, you can set this as a hard cut limit.

View Clip Offset

View Clip offset is a tool allowing you to hard cut and create a “window clip in” style effect on your total render. It will just cut all points outside that range on final render.

Scene Settings

The scene settings are the core of your point optimizations. Here you will control all visible and blanked points for your frame, with detailed controls for different types of lines, curves and corners.

Its also where you can control colors, soft lines and other render level effects for points.

Point Spacing

Point Spacing is the bulk of where you will control your settings.

Auto Blanked Points

Settings related to blanked anchors rendered in the frames.

  • At Line Beginnings: This is how many blank anchors will be placed at the start of visible lines.
  • At Line Endings: This is how many blank anchors will be placed at the end of visible lines.
  • At Round Overlaps: This is how many blank anchors will be placed on each end of a round overlap.
Auto Anchor Points

Settings related to visible anchors rendered in the frames.

  • Accelerate/ Decelerate: Enables point counts to be adjusted based on theretical speed of the scanner leading into that point
  • At line beginnings: Visible points placed at the beginning of a visible line.
  • At line endings: Visible points placed at the end of a visible line.
  • At round overlaps: Visible points placed at the start and finish of round overlap lines.
  • At Corners 0-45: Visible anchors applied to visible corners that fall between 0 degrees and 45 degrees.
  • At Corners 45-90: Visible anchors applied to visible corners that fall between 45 degrees and 90 degrees.
  • At Corners 90-135: Visible anchors applied to visible corners that fall between 90 degrees and 135 degrees.
  • At corners 135-155: Visible anchors applied to visible corners that fall between 135 degrees and 155 degrees.
  • At Corners 155-165: Visible anchors applied to visible corners that fall between 155 degrees and 165 degreees.
  • At Corners 165-175: Visible anchors applied to visible corners that fall between 165 degrees and 175 degrees.
  • Corner detect: From 0-100, this is a confidence value the renderer will use when detecting the above corner angles.
AutoSpace Distance

The spacing of visible and blanked lines in the rendered frames.

  • Blanked Lines: The amount of space in between each point in its value for blanked lines. Larger number is more space and less total points.
  • Straight Lines: The amount of space in between each point in its value for visible lines. Larger number is more space and less total points.
  • Curved Lines: The amount of space in between each point when a curve is detected. Larger number is more space and less total points.
  • Curve Detection: From 0-100, this is a confidence value the renderer will use when detecting curves vs straight lines.

Beam Path

The beam path is how the renderer will place points in order.

  • No Optimization: Searches for the next detected line instead of finding the closest.
  • Linear Optimization: Searches for start points that go left to right even if the end of a line is towards the right.
  • Circular Optimization: Searchers for start points in a circular pattern around the center of the rendered frame.
  • Aggressive Optimization: Searches for the shortest path from an end of a line to the next line.
  • No Optimization will just go by detection or object order.

Color Setting

Color settings allow you to recolor traced lines if they are not the exact color needed for the rendered image.

  • Stroke Color: Finds the color of a “stroke”. Relevant for AI files. Then allows you to replace and swap.
  • Fill Color: Finds the fill color inside the traced line first, then allows you to replace specific color. (Most trace types this won't be found)
  • Custom Color: Allows you to recolor an entire Trace Layer, and is the most likely recolor mode you will use.

Once you select your mode, you can also use the custom color to find the right color to replace, and then just press replace. If you just select custom color, the custom color is ignored and you just select the replace color.

Replace Black will take lines rendered as black, and turn them into visible lines at the selected color.

Filter Setting

Filter settings will allow you to detect and remove extremely tight points, and small detections, so they can be filtered out of the rendered image. Its important to note that the detection pane is where most clean up of dense points should be done, and this is to protect the renderer engine itself from noise.

Soft Line

Soft Line allows you to add softened edges to the beginning and ends of lines along the visible line path. This can soften corners visually and give a more mature look to content. This filter is applied to the entire Trace layer.

  • Enable Soft line: Enables the soft line endings filter.
  • At line beginnings: The number of visible points in line from the beginning of a frame to be part of the faded edge.
  • At line endings: The number of visible points in a line from the end of a frame to be part of the faded edge.
  • At round overlaps: The number of visible points to be part of the faded edge when its detected as part of a round overlap.
  • at line angle: The number of visible points to bart of a faded edge when soft line gets applied to a detected corner.
  • Minimum level brightness: The lowest brightness value used in the faded edge.
  • Brightness Linearity: The fade curve log value used to determine brightness of each point, values 0-1. 1 is fully linear, .1 is logarithmic.

Beam Brush

Beam Brush filter allows you to add brush values to points within the renderer. This acts as a fade of values similar to the soft line endings filter. Setting minimum and maximum brush for a stroke. (This render filter may not detect all line types from the PMT)

  • Enable Beam Brush: Enables the filter to be applied to the current Trace Layer
  • Min Beam Brush for Stroke: The smallest brush value applied to the brush fade of the stroke.
  • Max Beam Brush for Stroke: The largest brush value applied to the brush fade of the stroke.
  • Brightness for Min Brush %: Brush filter applies a brightness on top of brush to normalize apparent brightness when beams are diverged. This is the small brush value brightness percentage.
  • Brightness for Max Brush %: This is the large brush value brightness percentage.
  • Brightness Linearity: The fade curve log value used to determine brightness of each point, values 0-1. 1 is fully linear, .1 is logarithmic.
pangolin_media_tracer.txt · Last modified: by Lyra Letournea

Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki